<!DOCTYPE html>
<html style="margin:0px!important;">
<head>
<meta name="viewport" content="width=device-width,maximum-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes">
<link rel="stylesheet" media="screen" href="https://www.thenortherner.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css" />  
<link rel="Shortcut Icon" href="https://www.thenortherner.com/wp-content/uploads/2015/10/200.png" type="image/x-icon" />


<script src="https://www.thenortherner.com/wp-content/themes/snoflex/javascript/jquery.min.js"></script>
<script type="text/javascript" src="https://www.thenortherner.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js"></script>
<script type="text/javascript" src="https://www.thenortherner.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js"></script> 
<link rel="stylesheet" href="https://www.thenortherner.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css" type="text/css">
<script src="https://www.thenortherner.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js"></script>
<script src="https://www.thenortherner.com/wp-content/themes/snoflex/javascript/jquery-visible.js"></script>
<script> 
 
    $(document).ready(function(){ 
        $("ul.sf-menu").supersubs({ 
            minWidth:    12,   // minimum width of sub-menus in em units 
            maxWidth:    20,   // maximum width of sub-menus in em units 
            extraWidth:  1     // extra width can ensure lines don't sometimes turn over 
        }).superfish({
    		delay:      200,     
        	speed:		'fast'
        });  // call supersubs first, then superfish, so that subs are 
                         // not display:none when measuring. Call before initialising 
                         // containing tabs for same reason. 
    }); 

</script>

<title>The Northerner | Editor’s picks: Our favorite albums of 2018</title>
<script type="text/javascript" src="https://www.thenortherner.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js"></script> 
<script type="text/javascript" src="https://www.thenortherner.com/wp-content/themes/snoflex/javascript/remodal.min.js"></script> 
 <link rel="stylesheet" href="https://www.thenortherner.com/wp-content/themes/snoflex/javascript/remodal.css"> 
 <link rel="stylesheet" href="https://www.thenortherner.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css"> 
<script>

	$(function () {

		$('#gototop').click(function () {
     var bottomPosition = $(".phototop").height();
     var bottomWindow = $(window).height();
     bottomWindow = bottomWindow - 50;
     if (bottomWindow < bottomPosition) {
     	photoHeight = bottomWindow;
		 photoHeight = photoHeight -45;
     } else {
     	photoHeight = bottomPosition +35;
     }
     $('html, body').animate({
         scrollTop: $("#mainbody").offset().top-photoHeight
     }, 1000).delay();
			return false;
		});
	})


	
</script>
<title>Editor’s picks: Our favorite albums of 2018 &#8211; The Northerner</title>
<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Northerner &raquo; Editor’s picks: Our favorite albums of 2018 Comments Feed" href="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thenortherner.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.0.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
		<style type="text/css">
				</style>
	<link rel='stylesheet' id='wp_pro_ads_style-css'  href='https://www.thenortherner.com/wp-content/plugins/wp_pro_ad_system/templates/css/wpproads.min.css?ver=4.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='farbtastic-css'  href='https://www.thenortherner.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.thenortherner.com/wp-includes/css/dashicons.min.css?ver=5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.thenortherner.com/wp-includes/js/thickbox/thickbox.css?ver=5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://www.thenortherner.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.thenortherner.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://www.thenortherner.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.thenortherner.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.11.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.thenortherner.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://www.thenortherner.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.10.2' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.thenortherner.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.74.1' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.thenortherner.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Nixie+One%3A400%2C700%7CLato%3A400%2C700%7CMontserrat%3A400%2C700%7CAdamina%3A400%2C700%7CNeuton%3A400%2C700&#038;ver=5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://www.thenortherner.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20180212' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://www.thenortherner.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://www.thenortherner.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://www.thenortherner.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://www.thenortherner.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://www.thenortherner.com/wp-content/themes/snoflex/style.css?ver=20181207' type='text/css' media='all' />
<link rel='stylesheet' id='sccss_style-css'  href='https://www.thenortherner.com/?sccss=1&#038;ver=5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.thenortherner.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.thenortherner.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://www.thenortherner.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.0.5' type='text/css' media='screen' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.thenortherner.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/wp_pro_ad_system/templates/js/wppas.js?ver=5.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20150408'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/javascript/jquery.min.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=5.0.2'></script>
<link rel='https://api.w.org/' href='https://www.thenortherner.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thenortherner.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thenortherner.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Men&#8217;s basketball vanquishes Flames at BB&#038;T Arena 73-58' href='https://www.thenortherner.com/sports/2018/12/30/mens-basketball-vanquishes-flames-at-bbt-arena-73-58/' />
<meta name="generator" content="WordPress 5.0.2" />
<link rel="canonical" href="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/" />
<link rel='shortlink' href='https://wp.me/p8qcV4-hlv' />
<link rel="alternate" type="application/json+oembed" href="https://www.thenortherner.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thenortherner.com%2Ffeature-on-homepage%2F2019%2F01%2F01%2Feditors-picks-our-favorite-albums-of-2018%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thenortherner.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thenortherner.com%2Ffeature-on-homepage%2F2019%2F01%2F01%2Feditors-picks-our-favorite-albums-of-2018%2F&#038;format=xml" />
    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 12px;
            position: relative;
            z-index: 1000;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.thenortherner.com"><link rel="https://theeventscalendar.com/" href="https://www.thenortherner.com/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
	<meta property="og:title" content="Editor’s picks: Our favorite albums of 2018" />
	<meta property="og:type" content="article" />
	<meta name="author" content="Northerner Staff" />
	<meta property="og:url" content="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/" />
	<meta property="og:image" content="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/2018-hits-sno-final-1.png?fit=900%2C780&ssl=1" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="780" />
	<meta property="og:site_name" content="The Northerner" />
	<meta property="og:description" content="Black Panther: the Album &#8211; Various Artists The Black Panther album, released in February alongside the record-shattering movie, created anthems for the summer, Instagram captions and more, and the entire project was overseen by none other than Kendrick Lamar. In the 14-song album, you are invited into the contrasting worlds of Marvel superhero T’Challa and..." />
	<meta name="description" content="Black Panther: the Album &#8211; Various Artists The Black Panther album, released in February alongside the record-shattering movie, created anthems for the summer, Instagram captions and more, and the entire project was overseen by none other than Kendrick Lamar. In the 14-song album, you are invited into the contrasting worlds of Marvel superhero T’Challa and..." />
	<meta property="article:section" content="A&amp;L Features" />
	<meta property="article:tag" content="" />
<!-- End of Facebook Meta Tags -->
<meta property="og:site_name" content="The Northerner" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="618099528257678" />
<meta property="og:url" content="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/" />
<meta property="og:title" content="Editor’s picks: Our favorite albums of 2018" />
<meta property="og:description" content="Black Panther: the Album - Various Artists The Black Panther album, released in February alongside the record-shattering movie, created anthems for the summer, Instagram captions and more, and the entire project was overseen by none other than Kendrick Lamar. In the 14-song album, you are invited into the contrasting worlds of Marvel superhero T’Challa and&hellip;" />
<meta property="og:image" content="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/2018-hits-sno-final-1.png?fit=1498%2C1299&amp;ssl=1" />
<meta property="og:image:width" content="1498" />
<meta property="og:image:height" content="1299" />
<meta property="og:image" content="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-BROCKHAMPTON.png?fit=733%2C678&amp;ssl=1" />
<meta property="og:image:width" content="733" />
<meta property="og:image:height" content="678" />
<meta property="og:image" content="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-Snail-Mail.png?fit=733%2C678&amp;ssl=1" />
<meta property="og:image:width" content="733" />
<meta property="og:image:height" content="678" />
<meta property="article:published_time" content="2019-01-01T14:00:33+00:00" />
<meta property="article:modified_time" content="2019-01-01T20:17:33+00:00" />
<meta property="article:author" content="https://www.thenortherner.com/author/kellyj1/" />
<meta property="article:section" content="A&amp;L Features" />
<meta property="article:tag" content="Featured Story" />
<style type="text/css" media="screen">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</style></head>
<body data-rsssl=1>


<div id="lf_wrap">
<div id="sno_longform" class="sno-story-66681">
	
		<style>
				#wpadminbar {display:none!important;}
			</style><div class='header' style='display:none;'><div class="altheader-menu"><div id="hover-menu"><div class="sno-menu menu-icon dashicons dashicons-menu"></div><div class="sno-menu close-icon foundation-icons fi-x" style="display:none;"></div></div></div><div class="lf_headerleft"><a href="/"><img src="https://www.thenortherner.com/wp-content/uploads/2016/08/facebookxx-475x475.jpg" alt="The Independent Student Newspaper of Northern Kentucky University." /></a></div><div class="socialmedia"><div class="sharing sharing-top"><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.thenortherner.com%2Ffeature-on-homepage%2F2019%2F01%2F01%2Feditors-picks-our-favorite-albums-of-2018%2F" title="Share on Facebook" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Editor%E2%80%99s+picks%3A+Our+favorite+albums+of+2018&amp;url=https%3A%2F%2Fwp.me%2Fp8qcV4-hlv" title="Tweet This Story" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a aria-hidden="true" data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a></div>			<script type="text/javascript">
				$(document).ready(function() {
					$(function(){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '66681';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $("#suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<label for="email_to_Bar" style="display:none;">Send email to this address</label>
  				<input type="text" id="email_to_Bar" name="email_to_Bar" class="sno_email_fields" placeholder="Send email to this address"><br />
  				
  				<label for="email_from_Bar" style="display:none;">Enter Your Name</label>
  				<input type="text" id="email_from_Bar" name="email_from_Bar" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				
  				<label for="email_comment_Bar" style="display:none;">Add a comment here</label>
  				<textarea rows="4" id="email_comment_Bar" name="email_comment_Bar" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				
  				<label for="human_Bar" style="display:none;">Verification</label>
  				<input type="text" id="human_Bar" name="human_Bar" class="sno_email_fields" placeholder="What's 7 + 1?"><br />

  				<br />
  				<button id="submit_email_Bar" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form" name="sno_email_submission_form" value="c0744ee4b7" /><input type="hidden" name="_wp_http_referer" value="/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/" />
  				</form>
  				</div>
			</div>
										<script>
								$(document).ready(function() {

								$(function(){
           							$('#submit_email_Bar').click(function(){
											var storyid = '66681';
											var datastring = '';
											if ($("#email_to_Bar").length > 0){
												var email_to = $('input[name=email_to_Bar]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Bar").length > 0){
												var email_from = $('input[name=email_from_Bar]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Bar").length > 0){
												var email_comment = $('textarea[name=email_comment_Bar]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Bar").length > 0){
												var human = $('input[name=human_Bar]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 8;

       										var verification = $('input[name=sno_email_submission_form]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $("#emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			</div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up fa fa-arrow-up"></div></a></div></div>
<div id="storypage">
<div id="altheader-searchbox"><ul class="slidemenu mobile-menu"><li class="mobile-search" style="margin-top: 0px; clear: both;"><form method="get" id="searchform-alt" action="https://www.thenortherner.com/">
									<label for="s" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
								</form></li><div class="mobile-menu"><ul id="menu-mobile" class="menu"><li id="menu-item-53997" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-53997"><a href="https://www.thenortherner.com/category/feature-on-homepage/">Featured Stories</a></li>
<li id="menu-item-53994" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53994"><a href="https://www.thenortherner.com/category/news/">News</a></li>
<li id="menu-item-64558" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64558"><a href="https://www.thenortherner.com/fall-2018/">Print Editions</a></li>
<li id="menu-item-53995" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53995"><a href="https://www.thenortherner.com/category/sports/">Sports</a></li>
<li id="menu-item-53992" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-53992"><a href="https://www.thenortherner.com/category/arts-and-life/">Arts &#038; Life</a></li>
<li id="menu-item-53996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53996"><a href="https://www.thenortherner.com/category/video/">Video</a></li>
<li id="menu-item-53993" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53993"><a href="https://www.thenortherner.com/category/multimedia-2/">Multimedia</a></li>
<li id="menu-item-54041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54041"><a href="https://www.thenortherner.com/contact-us/">Contact Us</a></li>
<li id="menu-item-54042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-54042"><a href="https://www.thenortherner.com/contribute/">Contribute</a></li>
</ul></div></ul></div><img src="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/2018-hits-sno-final-1.png?fit=1498%2C1299&ssl=1" style="width:100%" /><div class="lf-immersive-caption"><span class="photocredit"> (<a href="https://www.thenortherner.com/staff/?writer=Josh%20Kelly">Josh Kelly</a>)</span></div><style>.parallaxcontainer { height: auto !important; }</style><div id="mainbody"><div class="content main"><h1 id="storyheadline" class="storyheadline">Editor’s picks: Our favorite albums of 2018</h1><div class="dividingline storystart"></div><div class="storydeck"><p>We danced, we sang, we flossed sometimes a little too hard. Here's the albums that inspired those moments.</p></div><div class="dividinglinedeck"></div><p class="byline"> <a href="https://www.thenortherner.com/staff/?writer=Northerner%20Staff">Northerner Staff</a></p><p class="longdate"><span class="time-wrapper">January 1, 2019</span></p><div class="leftside storybody"><span class="storycontent"><div class="pf-content"><h3><em>Black Panther: the Album &#8211; Various Artists</em></h3>
<div id="attachment_66692" style="width: 240px" class="wp-caption alignleft"><a href="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Black-Panther.png?ssl=1"><img data-attachment-id="66692" data-permalink="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/attachment/me-black-panther/" data-orig-file="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Black-Panther.png?fit=733%2C678&amp;ssl=1" data-orig-size="733,678" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Me Black Panther" data-image-description="" data-medium-file="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Black-Panther.png?fit=475%2C439&amp;ssl=1" data-large-file="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Black-Panther.png?fit=733%2C678&amp;ssl=1" class="wp-image-66692" src="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Black-Panther.png?resize=230%2C200&#038;ssl=1" alt="" width="230" height="200" srcset="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Black-Panther.png?zoom=2&amp;resize=230%2C200&amp;ssl=1 460w, https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Black-Panther.png?zoom=3&amp;resize=230%2C200&amp;ssl=1 690w" sizes="(max-width: 230px) 100vw, 230px" data-recalc-dims="1" /></a><p class="wp-caption-text">Josh Kelly, Arts &amp; Life Editor</p></div>
<p>The Black Panther album, released in February alongside the record-shattering movie, created anthems for the summer, Instagram captions and more, and the entire project was overseen by none other than Kendrick Lamar.</p>
<p>In the 14-song album, you are invited into the contrasting worlds of Marvel superhero T’Challa and his arch-nemesis Erik Killmonger. One world is Oakland, California and the other the fictional African country Wakanda; the album brings together the two seamlessly. Lamar unites 27 artists of different musical backgrounds to form this jam-packed album.</p>
<p>Each artist brings out a different part of the two characters’ personalities. All the while, African instruments and chants can be heard in the background and make up a majority of the beats. The production challenges trap beats, yet still proves versatile enough to compete against R&amp;B sounds in the same gesture.</p>
<p>Tracks two and three use the same rhythm in varying ways. “X” by Schoolboy Q, 2 Chainz and Saudi is a rap song with the most elaborate and best beat on the album, while Khalid and Swae Lee’s pairing on “The Ways” flows almost as smooth as Okeye telling her husband she’d kill him for Wakanda.</p>
<p>The lyrics switch from English to Zulu, an African language native to Southern Africa, in a few of the albums songs. “Seasons” includes a beautiful verse in Zulu giving a message to the people of Southern Africa. The intention was to create a bond between non-African people and African people; instead of giving them a song in a language they can’t understand, Sjava gives them a verse that’s meant for them.</p>
<p>As a journalist (myself) once tweeted, the album “makes your melanin happy” upon one listen. With its unbearing reminder of T’Challa’s life and Future adding his two cents to “Slob on My Knob” there’s plenty to be proud of.</p>
<p style="text-align: right;">-Josh Kelly</p>
<hr />
<h3><em>777 &#8211; Key! &amp; Kenny Beats</em></h3>
<div id="attachment_66686" style="width: 240px" class="wp-caption alignright"><a href="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/kane-777.png?ssl=1"><img data-attachment-id="66686" data-permalink="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/attachment/kane-777/" data-orig-file="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/kane-777.png?fit=733%2C678&amp;ssl=1" data-orig-size="733,678" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="kane 777" data-image-description="" data-medium-file="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/kane-777.png?fit=475%2C439&amp;ssl=1" data-large-file="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/kane-777.png?fit=733%2C678&amp;ssl=1" class="wp-image-66686" src="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/kane-777.png?resize=230%2C213&#038;ssl=1" alt="" width="230" height="213" srcset="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/kane-777.png?resize=475%2C439&amp;ssl=1 475w, https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/kane-777.png?resize=300%2C277&amp;ssl=1 300w, https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/kane-777.png?w=733&amp;ssl=1 733w" sizes="(max-width: 230px) 100vw, 230px" data-recalc-dims="1" /></a><p class="wp-caption-text">Kane Mitten, Asst. Arts &amp; Life Editor</p></div>
<p>Atlanta rapper Key!—who is either completely or not at all responsible for the current sound of rap, depending on who you talk to—is someone whose music I had stopped checking for a long time ago. So when my friend and former Northerner Arts &amp; Life Editor Jude Noel texted me one morning in May, saying “you gotta check out this new key project!”, I shrugged it off. <i>It’s Key, </i>I thought. <i>I’m sure it’s decent; I’m just not really that interested. I’ll get around to it.</i> But <i>777 </i>is more than decent; it’s filled with amazing production, catchy hooks and emotional depth.</p>
<p>For an artist who’s been on the scene for more than a decade now, Key! isn’t as prominent as you’d think he would be. Even a feature on “U Guessed It,” the OG Maco song that launched a thousand Vine parodies, a prominent verse on Father’s 2014 viral hit song “Look At Wrist,” and his help in making artists such as 21 Savage, Playboi Carti and Post Malone rise to fame haven’t done much for his popularity. Key! doesn’t seem to mind though. “Thank you for ignoring me,” he says on album standout “Love on Ice.” “I don’t wanna be famous.”</p>
<p>Key’s unorthodox delivery and voice modulation has long been copied by artists all across the genre, but on <i>777 </i>he shows that the imitation can’t match the original. His punchline-driven style has never been better, with references ranging from country singers to anime to Star Wars to Legally Blonde. Every replay of <i>777 </i>reveals a joke or a callback to popular culture that you didn’t pick up on before, hiding in the background waiting to be discovered. A lot of the metaphors present on the album are so absurd you wonder how they were even conceived, like when Key! raps about his broken heart of ice and somehow works in a way to mention Olympic figure skater Kristi Yamaguchi in his rhymes.</p>
<p>The ticking heart of <i>777</i> is the excellent production work by Kenny Beats, who’s been on a tear this year after going from a virtually unknown producer to crafting some of the biggest rap hits of 2018. His pitched-up drums and warbly, complex synths are the perfect compliment to Key’s booming vocals. Every instrumental on the album feels just the right amount of crazy &#8211; complex enough to be like nothing you’ve heard before, yet simple and catchy enough that listeners will be replaying the beats in their mind all day.</p>
<p>Despite the in-your-face production and boisterous raps, Key! isn’t afraid to bare his soul on this project. Heartbreak, fractured relationships, and love are themes throughout the album’s snappy 35-minute runtime. One track has Key! reflecting on how his kids look just like him, while the haunting and ominous “Control” has him painfully yelling “You’ve been through so much, I know that love is hard to find” and “I’m trying to chase vanity, I’ve lost all control / I hear that all the time, I don’t wanna hear it no more.”</p>
<p>Key! is at his best here, delivering insanely clever bars and earworm melodies over incredible production, and the short runtime makes it easy to run the entire project back over and over.  <i>777</i> asks listeners a very simple question &#8211; “can ya dig it?”</p>
<p style="text-align: right;">-Kane Mitten</p>
<hr />
<h3 style="text-align: left;"><em>Lush &#8211; Snail Mail</em></h3>
<div id="attachment_66683" style="width: 240px" class="wp-caption alignleft"><a href="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-Snail-Mail.png?ssl=1"><img data-attachment-id="66683" data-permalink="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/attachment/sam-snail-mail/" data-orig-file="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-Snail-Mail.png?fit=733%2C678&amp;ssl=1" data-orig-size="733,678" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Sam Snail Mail" data-image-description="" data-medium-file="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-Snail-Mail.png?fit=475%2C439&amp;ssl=1" data-large-file="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-Snail-Mail.png?fit=733%2C678&amp;ssl=1" class="wp-image-66683" src="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-Snail-Mail.png?resize=230%2C213&#038;ssl=1" alt="" width="230" height="213" srcset="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-Snail-Mail.png?resize=475%2C439&amp;ssl=1 475w, https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-Snail-Mail.png?resize=300%2C277&amp;ssl=1 300w, https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-Snail-Mail.png?w=733&amp;ssl=1 733w" sizes="(max-width: 230px) 100vw, 230px" data-recalc-dims="1" /></a><p class="wp-caption-text">Sam Rosenstiel, Editor-in-Chief</p></div>
<p>Right out of high school, Lindsey Jordan has found a way to cleverly muse about the state of the world and the state of a teenage heart on <i>Lush</i>. Her debut as Snail Mail is notable for a few reasons, mostly that it’s a moody but never bratty reflection of modern romance, and it’s a kick of ‘90s nostalgia that feels brand new all at once.</p>
<p>“Stick” swirls in a reflective indie waltz. “Do you dream about people that wrong you, do you see those faces again and again,” Jordan croons as the ballad crescendos to a verbed-out guitar chorus. It’s a cross between the yearning pleas of The Cranberries and the decadence that makes Band of Horses songs so syrupy sweet. Jordan finds the balance that’s both in line with the indie music of 2018 but also timeless.</p>
<p>But it’s “Speaking Terms” on the A side of the LP that got me through my breakup. “Say what you gotta, sleep in somehow / Leave things on speaking terms, and I&#8217;ll see you around.” On the track, Jordan proves she’s the mistress of the minor chord with some rock swagger, but her voice drips with a pained, trembling quality over a churning guitar crunch. Break up with someone, listen to this record, drink some red wine and you’ll hear what I’m talking about. Pain is so 2017. Jordan knows it, and she’s made it all into something new.</p>
<p style="text-align: right;"><i>-Sam Rosenstiel</i></p>
<hr />
<h3><em>iridescence &#8211; BROCKHAMPTON</em></h3>
<div id="attachment_66682" style="width: 240px" class="wp-caption alignright"><a href="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-BROCKHAMPTON.png?ssl=1"><img data-attachment-id="66682" data-permalink="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/attachment/sam-brockhampton/" data-orig-file="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-BROCKHAMPTON.png?fit=733%2C678&amp;ssl=1" data-orig-size="733,678" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Sam BROCKHAMPTON" data-image-description="" data-medium-file="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-BROCKHAMPTON.png?fit=475%2C439&amp;ssl=1" data-large-file="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-BROCKHAMPTON.png?fit=733%2C678&amp;ssl=1" class="wp-image-66682" src="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-BROCKHAMPTON.png?resize=230%2C213&#038;ssl=1" alt="" width="230" height="213" srcset="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-BROCKHAMPTON.png?resize=475%2C439&amp;ssl=1 475w, https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-BROCKHAMPTON.png?resize=300%2C277&amp;ssl=1 300w, https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Sam-BROCKHAMPTON.png?w=733&amp;ssl=1 733w" sizes="(max-width: 230px) 100vw, 230px" data-recalc-dims="1" /></a><p class="wp-caption-text">Sam Rosenstiel, Editor-in-Chief</p></div>
<p>There has always been a madcap appeal to the world’s weirdest boy band, BROCKHAMPTON. Since emerging in 2015, possibly from a puddle of <a href="https://www.youtube.com/watch?v=PMZZUyos1kI">blue paint</a>, their aim has been to reclaim the term “boy band” as a clan of rappers, vocalists, guitarists, designers and wannabe drug lords that sport <a href="https://www.youtube.com/watch?v=7XFIp0HL_zE">bulletproof vests</a> at shows. Their brand is being loud as hell and throwing everything but the kitchen sink into their beats, lyrics and style. It’s evident in the group’s 2017 triptych SATURATION, which bore subversive should-be hits across its albums like the chock-full-o-name-drops “STAR,” the sunny roll call “GUMMY” and (my personal favorite) the frantic sax freakout “BOOGIE.”</p>
<p>Their 2018 LP “iridescence” doesn’t flip the script, and they continue to lay bedrock beats resembling anxiety attacks to support dialed-up MC bravado. Opener “NEW ORLEANS” offers a rap round-robin over a grating drone, and similarly “J’OUVERT” prowls with pumped-up synth and rhymes that seem to crack under their own weight. “DISTRICT” is another crowded and buzzing wall of sound. But it’s on tracks like “SAN MARCO” and “TONYA” that show the band’s restrained pop and R&amp;B sensibility. As you’d expect with a 15-track entry that clocks in at 48 minutes, “iridescence” feels jam-packed.</p>
<p>Fans might dismiss the album as the most palatable entry in BROCKHAMPTON’s catalog, but the boys take some risks and refine their voice. It’s evident on those less chaotic tracks like “TONYA” with piano that walks along chords over Ciaran Ruaridh McDonald’s soaring falsetto and frontman Kevin Abstract’s storytelling. The album’s accessibility shouldn’t be held against it, especially since the most inviting aspect of BROCKHAMPTON has always been its collaborative vibe. The music can be alienating, crass and even harsh, but it’s not hard to imagine yourself donning the blue paint and stepping to the mic yourself.</p>
<p style="text-align: right;"><em>-SR</em></p>
<hr />
<h3><em>Harlan &amp; Alondra &#8211; Buddy</em></h3>
<div id="attachment_66693" style="width: 240px" class="wp-caption alignleft"><a href="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Buddy.png?ssl=1"><img data-attachment-id="66693" data-permalink="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/attachment/me-buddy/" data-orig-file="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Buddy.png?fit=733%2C678&amp;ssl=1" data-orig-size="733,678" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Me Buddy" data-image-description="" data-medium-file="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Buddy.png?fit=475%2C439&amp;ssl=1" data-large-file="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Buddy.png?fit=733%2C678&amp;ssl=1" class="wp-image-66693" src="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Buddy.png?resize=230%2C213&#038;ssl=1" alt="" width="230" height="213" srcset="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Buddy.png?resize=475%2C439&amp;ssl=1 475w, https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Buddy.png?resize=300%2C277&amp;ssl=1 300w, https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2019/01/Me-Buddy.png?w=733&amp;ssl=1 733w" sizes="(max-width: 230px) 100vw, 230px" data-recalc-dims="1" /></a><p class="wp-caption-text">Josh Kelly, Arts &amp; Life Editor</p></div>
<p>Compton, California is home to rap legends and hip hop trailblazers. If you go to the intersection of Harlan Avenue &amp; Alondra Boulevard, you’ll find freshman rapper Buddy’s home, and the title for his breakthrough album.</p>
<p><i>Harlan &amp; Alondra </i>pin drops you into the mind of the Compton rapper. The album showcases the variety of emotions and mental states—each attached to a different music style—that a person experiences on their transition to adulthood and gives the listener a comforting reminder that they too have grown from their roots and continue to grow.</p>
<p>This album, at its core, is a coming-of-age film brought to the hip hop scene.</p>
<p>Buddy begins ushering you with “la da das,” lamenting the struggles of having fake friends, writing music and spending money when rent is due in a few days. Before you are four minutes into the album, his world starts to unravel before you. On the second track, he instead flips the narrative saying how proud he is of these struggles and is ultimately “Shameless” of his situation and happy in the moment.</p>
<p>Where Buddy begins to excel is his sound-switching. Accompanied by established artists like A$AP Ferg, Ty Dolla $ign, Snoop Dogg and Khalid, he matches each artist’s style with ease. His song “Black” with A$AP Ferg brings you back to Ferg’s <i>Trap Lord</i> album; while his collaboration with Snoop Dogg on “The Blue” incorporates the talkbox and flashes you to the ‘90s funk wave that brought Zapp and Roger’s “I Want to Be Your Man.”</p>
<p>Buddy begins to flex his own talent with his solo tracks and shows that when he is alone, he still can shift the sound with no difficulty. “Find Me 2” is almost a conversation Buddy has with himself telling himself he’s proud of how far he’s come, yet the chorus sings the song that I’m sure everyone has felt at some point, “I can’t see myself.”</p>
<p>“Trouble on Central” gives the feeling of strolling through campus on your Tuesday after a stressful day of classes. “Hey Up There” with Ty Dolla $ign flashes you to the late night car ride when you think about how you’re still in this stage of stuck-ness and moving toward your dream.</p>
<p>Buddy simply daps you up, tells you “I’m working toward my dreams, and you can too.”</p>
<p style="text-align: right;"><em>-JK</em></p>
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print(); return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://i1.wp.com/cdn.printfriendly.com/buttons/print-button.png?w=980&#038;ssl=1" alt="Print Friendly, PDF & Email" data-recalc-dims="1" /></a></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-66681" class="share-twitter sd-button share-icon no-text" href="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-66681" class="share-facebook sd-button share-icon no-text" href="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow noopener noreferrer" data-shared="sharing-google-66681" class="share-google-plus-1 sd-button share-icon no-text" href="https://www.thenortherner.com/feature-on-homepage/2019/01/01/editors-picks-our-favorite-albums-of-2018/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related Posts</em></h3>
</div></span></div></div><div class="clear"></div><div id="content" class="content main"><div class="relatedstories"><div class="storymeta" style="margin-bottom:0px;"><p style="text-align:center;font-size:16px;line-height:30px;">Other stories filed under <a href="https://www.thenortherner.com/category/arts-and-life/al-features/">A&amp;L Features</a></p></div><div class="relatedbody"><div class='catrow catstory-position-1'><a href="https://www.thenortherner.com/arts-and-life/campus-events/2018/10/10/karamo-brown-wows-su-crowd-with-message-of-love-self-esteem/" title="Karamo Brown wows SU crowd with message of love, self-esteem"><img src="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2018/10/IMG_7820.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="Karamo Brown wows SU crowd with message of love, self-esteem" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/arts-and-life/campus-events/2018/10/10/karamo-brown-wows-su-crowd-with-message-of-love-self-esteem/">Karamo Brown wows SU crowd with message of love, self-esteem</a></h5></div><div class='relateddividervert catstory-position-2'></div><div class='catrow catstory-position-2'><a href="https://www.thenortherner.com/arts-and-life/campus-arts/2018/10/08/norse-code-nkus-underground-radio-reimagined/" title="Norse Code: NKU&#8217;s underground radio reimagined"><img src="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2018/09/maya_shaffer_ncr-1-of-6.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="Norse Code: NKU&#8217;s underground radio reimagined" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/arts-and-life/campus-arts/2018/10/08/norse-code-nkus-underground-radio-reimagined/">Norse Code: NKU&#8217;s underground radio reimagined</a></h5></div><div class='relateddividervert catstory-position-3'></div><div class='catrow catstory-position-3'><a href="https://www.thenortherner.com/arts-and-life/campus-arts/2018/09/21/big-fish-musical-makes-a-splash-in-corbett/" title="Big Fish: Musical makes a splash in Corbett"><img src="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2018/09/IMG_7812.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="Big Fish: Musical makes a splash in Corbett" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/arts-and-life/campus-arts/2018/09/21/big-fish-musical-makes-a-splash-in-corbett/">Big Fish: Musical makes a splash in Corbett</a></h5></div><div class='relateddividervert catstory-position-4'></div><div class='catrow catstory-position-4'><a href="https://www.thenortherner.com/arts-and-life/campus-events/2018/09/14/50th-anniversary-film-fest-takes-students-back-to-1968/" title="50th anniversary film fest takes students back to 1968"><img src="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2018/09/Image-1-1.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="50th anniversary film fest takes students back to 1968" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/arts-and-life/campus-events/2018/09/14/50th-anniversary-film-fest-takes-students-back-to-1968/">50th anniversary film fest takes students back to 1968</a></h5></div><div class='relateddividervert catstory-position-5'></div><div class='catrow catstory-position-5'><a href="https://www.thenortherner.com/arts-and-life/2018/09/12/authors-journey-explores-spirit-of-mentorship/" title="Author&#8217;s journey explores spirit of mentorship"><img src="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2018/09/IMG_0873.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="Author&#8217;s journey explores spirit of mentorship" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/arts-and-life/2018/09/12/authors-journey-explores-spirit-of-mentorship/">Author&#8217;s journey explores spirit of mentorship</a></h5></div><div class="clear"></div></div></div><div class="clear"></div><div class="relatedstories"><div class="storymeta" style="margin-bottom:0px;"><p style="text-align:center;font-size:16px;line-height:30px;">Other stories filed under <a href="https://www.thenortherner.com/category/feature-on-homepage/">Featured Story</a></p></div><div class="relatedbody"><div class='catrow catstory-position-1'><a href="https://www.thenortherner.com/sports/2018/12/30/mens-basketball-vanquishes-flames-at-bbt-arena-73-58/" title="Men&#8217;s basketball vanquishes Flames at BB&#038;T Arena 73-58"><img src="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2018/12/NKU-MB-VS-UIC-Northerner-14.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="Men&#8217;s basketball vanquishes Flames at BB&#038;T Arena 73-58" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/sports/2018/12/30/mens-basketball-vanquishes-flames-at-bbt-arena-73-58/">Men&#8217;s basketball vanquishes Flames at BB&#038;T Arena 73-58</a></h5></div><div class='relateddividervert catstory-position-2'></div><div class='catrow catstory-position-2'><a href="https://www.thenortherner.com/sports/2018/12/30/womens-basketball-fall-to-jaguars-48-70/" title="Women&#8217;s basketball falls to Jaguars 48-70"><img src="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2018/12/womens-basketball.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="Women&#8217;s basketball falls to Jaguars 48-70" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/sports/2018/12/30/womens-basketball-fall-to-jaguars-48-70/">Women&#8217;s basketball falls to Jaguars 48-70</a></h5></div><div class='relateddividervert catstory-position-3'></div><div class='catrow catstory-position-3'><a href="https://www.thenortherner.com/sports/2018/12/28/womens-basketball-defeats-uic-67-49/" title="Women&#8217;s basketball defeats UIC Flames 67-49"><img src="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2018/12/womens-basketball.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="Women&#8217;s basketball defeats UIC Flames 67-49" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/sports/2018/12/28/womens-basketball-defeats-uic-67-49/">Women&#8217;s basketball defeats UIC Flames 67-49</a></h5></div><div class='relateddividervert catstory-position-4'></div><div class='catrow catstory-position-4'><a href="https://www.thenortherner.com/sports/2018/12/28/norse-defeat-jaguars-92-77-to-open-horizon-league-play/" title="Norse defeat Jaguars 92-77 to open conference play"><img src="https://i1.wp.com/www.thenortherner.com/wp-content/uploads/2018/12/DOne-quick-1.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="Norse defeat Jaguars 92-77 to open conference play" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/sports/2018/12/28/norse-defeat-jaguars-92-77-to-open-horizon-league-play/">Norse defeat Jaguars 92-77 to open conference play</a></h5></div><div class='relateddividervert catstory-position-5'></div><div class='catrow catstory-position-5'><a href="https://www.thenortherner.com/sports/2018/12/21/norse-notch-10th-win-with-victory-over-huskies/" title="Norse notch 10th win with victory over Huskies"><img src="https://i2.wp.com/www.thenortherner.com/wp-content/uploads/2018/12/NKU-MB-VS-NIU-Shrunk-7.jpg?resize=240%2C150&ssl=1" class="catstory-photo" alt="Norse notch 10th win with victory over Huskies" /></a><h5 class="relatedtitle"><a href="https://www.thenortherner.com/sports/2018/12/21/norse-notch-10th-win-with-victory-over-huskies/">Norse notch 10th win with victory over Huskies</a></h5></div><div class="clear"></div></div></div><div class="clear"></div></div><div class="footerbar"><p><a href="https://www.thenortherner.com">The Northerner</a> &bull; Copyright 2019 &bull; <a href="http://snosites.com/why-sno/">FLEX WordPress Theme</a> by <a href="https://snosites.com">SNO</a> &bull; <a href="https://www.thenortherner.com/wp-login.php">Log in</a></p></div><!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.thenortherner.com/wp-admin/admin-ajax.php";
</script>

		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-22842225-27', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
			<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
			<div style="display:none">
	</div>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};var tribe_system_info = {"sysinfo_optin_nonce":"0ffe299d2d","clipboard_btn_text":"Copy to clipboard","clipboard_copied_text":"System info copied","clipboard_fail_text":"Press \"Cmd + C\" to copy"};/* ]]> */ </script>      <script type="text/javascript">

          var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.thenortherner.com\/feature-on-homepage\/2019\/01\/01\/editors-picks-our-favorite-albums-of-2018\/":66681};
	</script>
				<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://www.thenortherner.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://www.thenortherner.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/wp_pro_ad_system/templates/js/jquery.jshowoff.min.js?ver=5.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.thenortherner.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"","font_method":"svg"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.10.2'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201901'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.thenortherner.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.74.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"618099528257678"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="https:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-includes/js/wp-embed.min.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.thenortherner.com\/wp-admin\/admin-ajax.php","nonce":"0525d1fcab","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.thenortherner.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.thenortherner.com%2Ffeature-on-homepage%2F2019%2F01%2F01%2Feditors-picks-our-favorite-albums-of-2018%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20170209'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thenortherner.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.8.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<div id="fb-root"></div><script type='text/javascript' src='https://stats.wp.com/e-201901.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.8.1',blog:'124456882',post:'66681',tz:'-5',srv:'www.thenortherner.com'} ]);
	_stq.push([ 'clickTrackerInit', '124456882', '66681' ]);
</script>

   </div>

</div>
</div>
</div>
</body>

<script type="text/javascript">
// start of scroll to view

$(document).ready(function() {

var win = $(window);
var allMods = $(".sno-animate");
var allWPcaptions = $(".wp-caption");

// Already visible modules
allMods.each(function(i, el) {
  var el = $(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
});
allWPcaptions.each(function(i, el) {
  var el = $(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
});


$(window).scroll(function(event) {
  
  $(".sno-animate").each(function(i, el) {
    var el = $(el);
    if (el.visible(true)) {
      el.addClass("come-in");     
    } 
  });
  $(".wp-caption").each(function(i, el) {
    var el = $(el);
    if (el.visible(true)) {
      el.addClass("come-in");     
    } 
  });
  
});


});
//end of scroll to view
</script>
<script type="text/javascript">
    			$("#hover-menu").click(function(){
				    $("#altheader-searchbox").toggle('slow');					
				});  
				
								if ($('.slidemenu').is(":visible")) {
									$('.hidethis').css({ visibility: "hidden" });
									$('#altheader-searchbox').css({ zIndex: "1001"});
								} else {
									$('.hidethis').css({ visibility: "visible" });
									$('#altheader-searchbox').css({ zIndex: "99"});
								}

			$('.sno-menu').click(function() {
			
				$('#hoverbar_menu').fadeToggle();
				$('.menu-icon').toggle();
				$('.close-icon').toggle();
				$('#hoverbar_menu').css({ height: $(window).height() - 50 });
			
			});


</script>
<script type="text/javascript">
		$("a[href='#slideshow']").on('click', function(event) { return false; });
		$("a[href='#photo']").on('click', function(event) { return false; });
		$("#snotop").hide();
	
		$(function () {
			$(window).scroll(function () {
				if ($(this).scrollTop() > 400) {
					$('#snotop').fadeIn();
				} else {
					$('#snotop').fadeOut();
				}
				if ($(this).scrollTop() > 200) {
					$('.header').fadeIn();
				}
				
			});

			$('#back-top a').click(function () {
				$('body,html').animate({
					scrollTop: 0
				}, 800);
				return false;
			});

		});

			$(document).ready(function () {
				var top_elements = jQuery('#mainbody').offset().top;
				var wp_adminbar = 0;
				if (jQuery('#wpadminbar').length > 0) wp_adminbar = jQuery('#wpadminbar').height();
				
				var jumpbutton = top_elements + 20;
				var headerLocation   = $("#mainbody").offset().top;
				$(window).scroll(function () {
					if ($(this).scrollTop() > (headerLocation - $(window).height()) ) {
						$('#jump-arrow').fadeOut();
					} else {
						$('#jump-arrow').fadeIn();
					}
				});

				$('#jump-arrow').click(function () {
					$('html, body').animate({ scrollTop: $("#mainbody").offset().top - wp_adminbar }, 500);
					return false;
				});
			
			});

	</script>


</html>
<!-- Page generated by LiteSpeed Cache 2.8.1 on 2019-01-01 15:21:41 -->